What’s Vulnerable › Vulnerabilities
CVE-2026-31887: Shopware unauthenticated data extraction possible through store-api.order endpoint
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-11 · updated 2026-06-17
- Weakness: CWE-863
Description
Shopware is an open commerce platform. Prior to 6.7.8.1 and 6.6.10.15, an insufficient check on the filter types for unauthenticated customers allows access to orders of other customers. This is part of the deepLinkCode support on the store-api.order endpoint. This vulnerability is fixed in 6.7.8.1 and 6.6.10.15.
Affected products
- shopware: before 6.6.10.15; from 6.7.0.0 before 6.7.8.1 — fixed in 6.6.10.15, 6.7.8.1
How to fix
Upgrade to a fixed version: shopware 6.6.10.15, 6.7.8.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-31887 or the next vulnerability affects your stack