What’s Vulnerable › Vulnerabilities
CVE-2026-31901: Parse Server has user enumeration via email verification endpoint
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-11 · updated 2026-06-17
- Weakness: CWE-204
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 8.6.34 and 9.6.0-alpha.8, the email verification endpoint (/verificationEmailRequest) returns distinct error responses depending on whether an email address belongs to an existing user, is already verified, or does not exist. An attacker can send requests with different email addresses and observe the error codes to determine which email addresses are registered in the application. This is a user enumeration vulnerability that affects any Parse Server deployment with email verification enabled (verifyUserEmails: true). This vulnerability is fixed in 8.6.34 and 9.6.0-alpha.8.
Affected products
- parse-community parse-server: before 8.6.34; from 9.0.0 before 9.6.0; 9.6.0-alpha1, 9.6.0-alpha2, 9.6.0-alpha3, 9.6.0-alpha4, 9.6.0-alpha5, 9.6.0-alpha6 (+1) — fixed in 8.6.34, 9.6.0
How to fix
Upgrade to a fixed version: parse-community parse-server 8.6.34, 9.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/releases/tag/8.6.34
- https://github.com/parse-community/parse-server/releases/tag/9.6.0-alpha.8
- https://github.com/parse-community/parse-server/security/advisories/GHSA-w54v-hf9p-8856
Get alerted when CVE-2026-31901 or the next vulnerability affects your stack