What’s Vulnerable › Vulnerabilities

CVE-2026-31908: Apache APISIX: forward auth plugin allows header injection

Description

Header injection vulnerability in Apache APISIX. The attacker can take advantage of certain configuration in forward-auth plugin to inject malicious headers. This issue affects Apache APISIX: from 2.12.0 through 3.15.0. Users are recommended to upgrade to version 3.16.0, which fixes the issue.

Affected products

How to fix

Upgrade to a fixed version: Apache Software Foundation Apache APISIX 3.16.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-31908 or the next vulnerability affects your stack