What’s Vulnerable › Vulnerabilities
CVE-2026-31910: Apache OFBiz: Improper Input Validation in UI Factory Classes Leads to SSRF and Blind File Access
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-19 · updated 2026-10-14
- Weakness: CWE-918
Description
Server-Side Request Forgery (SSRF) vulnerability in Apache OFBiz. This issue affects Apache OFBiz: before 24.09.06. Users are recommended to upgrade to version 24.09.06, which fixes the issue.
Affected products
- Apache Software Foundation Apache OFBiz: before 24.09.06 — fixed in 24.09.06
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache OFBiz 24.09.06. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/2smc4c4o056ovd2hoq1l29593y5y29vh
- http://www.openwall.com/lists/oss-security/2026/05/19/24
Get alerted when CVE-2026-31910 or the next vulnerability affects your stack