What’s Vulnerable › Vulnerabilities
CVE-2026-31911: abort() in libpcap before 1.10.7 on an invalid BPF opcode
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-05 · updated 2026-09-08
- Weakness: CWE-617
Description
libpcap BPF interpreter calls abort() if it encounters a BPF instruction that has an invalid opcode. In particular uncommon use cases a crafted filter program can terminate the OS process.
Affected products
- The Tcpdump Group libpcap: before 1.10.7 — fixed in 1.10.7
How to fix
Upgrade to a fixed version: The Tcpdump Group libpcap 1.10.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-31911 or the next vulnerability affects your stack