What’s Vulnerable › Vulnerabilities

CVE-2026-31923: Apache APISIX: Openid-connect `tls_verify` field is disabled by default

Description

Cleartext Transmission of Sensitive Information vulnerability in Apache APISIX. This can occur due to `ssl_verify` in openid-connect plugin configuration being set to false by default. This issue affects Apache APISIX: from 0.7 through 3.15.0. Users are recommended to upgrade to version 3.16.0, which fixes the issue.

Affected products

How to fix

Upgrade to a fixed version: Apache Software Foundation Apache APISIX 3.16.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-31923 or the next vulnerability affects your stack