What’s Vulnerable › Vulnerabilities

CVE-2026-31924: Apache APISIX: Plugin tencent-cloud-cls log export uses plaintext HTTP

Description

Cleartext Transmission of Sensitive Information vulnerability in Apache APISIX. tencent-cloud-cls log export uses plaintext HTTP This issue affects Apache APISIX: from 2.99.0 through 3.15.0. Users are recommended to upgrade to version 3.16.0, which fixes the issue.

Affected products

How to fix

Upgrade to a fixed version: Apache Software Foundation Apache APISIX 3.16.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-31924 or the next vulnerability affects your stack