What’s Vulnerable › Vulnerabilities
CVE-2026-31992: OpenClaw < 2026.2.23 - Allowlist Exec-Guard Bypass via env -S
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-19 · updated 2026-06-17
- Weakness: CWE-184
Description
OpenClaw versions prior to 2026.2.23 contain an allowlist bypass vulnerability in system.run guardrails that allows authenticated operators to execute unintended commands. When /usr/bin/env is allowlisted, attackers can use env -S to bypass policy analysis and execute shell wrapper payloads at runtime.
Affected products
- OpenClaw: before 2026.2.23 — fixed in 2026.2.23
How to fix
Upgrade to a fixed version: OpenClaw 2026.2.23. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/commit/3f923e831364d83d0f23499ee49961de334cf58b
- https://github.com/openclaw/openclaw/commit/a1c4bf07c6baad3ef87a0e710fe9aef127b1f606
- https://github.com/openclaw/openclaw/security/advisories/GHSA-48wf-g7cp-gr3m
- https://www.vulncheck.com/advisories/openclaw-allowlist-exec-guard-bypass-via-env-s
Get alerted when CVE-2026-31992 or the next vulnerability affects your stack