What’s Vulnerable › Vulnerabilities
CVE-2026-31993: OpenClaw < 2026.2.22 - Allowlist Parsing Mismatch in system.run Shell Chains
- Severity: medium (CVSS 6.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-19 · updated 2026-06-17
- Weakness: CWE-184
Description
OpenClaw versions prior to 2026.2.22 contain an allowlist parsing mismatch vulnerability in the macOS companion app that allows authenticated operators to bypass exec approval checks. Attackers with operator.write privileges and a paired macOS beta node can craft shell-chain payloads that pass incomplete allowlist validation and execute arbitrary commands on the paired host.
Affected products
- OpenClaw: before 2026.2.22 — fixed in 2026.2.22
How to fix
Upgrade to a fixed version: OpenClaw 2026.2.22. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/commit/5da03e622119fa012285cdb590fcf4264c965cb5
- https://github.com/openclaw/openclaw/commit/e371da38aab99521c4e076cd3d95fd775e00b784
- https://github.com/openclaw/openclaw/security/advisories/GHSA-5f9p-f3w2-fwch
- https://www.vulncheck.com/advisories/openclaw-allowlist-parsing-mismatch-in-system-run-shell-chains
Get alerted when CVE-2026-31993 or the next vulnerability affects your stack