What’s Vulnerable › Vulnerabilities
CVE-2026-31998: OpenClaw 2026.2.22 < 2026.2.24 - Authorization Bypass in Synology Chat Plugin via Empty allowedUserIds
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-19 · updated 2026-06-17
- Weakness: CWE-863
Description
OpenClaw versions 2026.2.22 and 2026.2.23 contain an authorization bypass vulnerability in the synology-chat channel plugin where dmPolicy set to allowlist with empty allowedUserIds fails open. Attackers with Synology sender access can bypass authorization checks and trigger unauthorized agent dispatch and downstream tool actions.
Affected products
- OpenClaw: from 2026.2.22 before 2026.2.24 — fixed in 2026.2.24
How to fix
Upgrade to a fixed version: OpenClaw 2026.2.24. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/commit/0ee30361b8f6ef3f110f3a7b001da6dd3df96bb5
- https://github.com/openclaw/openclaw/commit/7655c0cb3a47d0647cbbf5284e177f90b4b82ddb
- https://github.com/openclaw/openclaw/security/advisories/GHSA-gw85-xp4q-5gp9
- https://www.vulncheck.com/advisories/openclaw-authorization-bypass-in-synology-chat-plugin-via-empty-alloweduserids
Get alerted when CVE-2026-31998 or the next vulnerability affects your stack