What’s Vulnerable › Vulnerabilities
CVE-2026-32023: OpenClaw < 2026.2.24 - Approval Gating Bypass via Dispatch-Wrapper Depth-Cap Mismatch in system.run
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-19 · updated 2026-06-17
- Weakness: CWE-863
Description
OpenClaw versions prior to 2026.2.24 contain an approval gating bypass vulnerability in system.run allowlist mode where nested transparent dispatch wrappers can suppress shell-wrapper detection. Attackers can exploit this by chaining multiple dispatch wrappers like /usr/bin/env to execute /bin/sh -c commands without triggering the expected approval prompt in allowlist plus ask=on-miss configurations.
Affected products
- OpenClaw: before 2026.2.24 — fixed in 2026.2.24
How to fix
Upgrade to a fixed version: OpenClaw 2026.2.24. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/commit/57c9a18180c8b14885bbd95474cbb17ff2d03f0b
- https://github.com/openclaw/openclaw/security/advisories/GHSA-ccg8-46r6-9qgj
- https://www.vulncheck.com/advisories/openclaw-approval-gating-bypass-via-dispatch-wrapper-depth-cap-mismatch-in-system-run
Get alerted when CVE-2026-32023 or the next vulnerability affects your stack