What’s Vulnerable › Vulnerabilities
CVE-2026-32033: OpenClaw < 2026.2.24 - Path Traversal via @-prefixed Absolute Paths in Workspace Boundary Validation
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-19 · updated 2026-06-17
- Weakness: CWE-22
Description
OpenClaw versions prior to 2026.2.24 contain a path traversal vulnerability where @-prefixed absolute paths bypass workspace-only file-system boundary validation due to canonicalization mismatch. Attackers can exploit this by crafting @-prefixed paths like @/etc/passwd to read files outside the intended workspace boundary when tools.fs.workspaceOnly is enabled.
Affected products
- OpenClaw: before 2026.2.24 — fixed in 2026.2.24
How to fix
Upgrade to a fixed version: OpenClaw 2026.2.24. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/commit/9ef0fc2ff8fa7b145d1e746d6eb030b1bf692260
- https://github.com/openclaw/openclaw/security/advisories/GHSA-27cr-4p5m-74rj
- https://www.vulncheck.com/advisories/openclaw-path-traversal-via-prefixed-absolute-paths-in-workspace-boundary-validation
Get alerted when CVE-2026-32033 or the next vulnerability affects your stack