What’s Vulnerable › Vulnerabilities
CVE-2026-32042: OpenClaw < 2026.2.25 - Privilege Escalation via Unpaired Device Identity in Shared Gateway Authentication
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-21 · updated 2026-06-17
- Weakness: CWE-863
Description
OpenClaw versions 2026.2.22 prior to 2026.2.25 contain a privilege escalation vulnerability allowing unpaired device identities to bypass operator pairing requirements and self-assign elevated operator scopes including operator.admin. Attackers with valid shared gateway authentication can present a self-signed unpaired device identity to request and obtain higher operator scopes before pairing approval is granted.
Affected products
- OpenClaw: from 2026.2.22 before 2026.2.25 — fixed in 2026.2.25
How to fix
Upgrade to a fixed version: OpenClaw 2026.2.25. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/commit/8d1481cb4a9d31bd617e52dc8c392c35689d9dea
- https://github.com/openclaw/openclaw/security/advisories/GHSA-553v-f69r-656j
- https://www.vulncheck.com/advisories/openclaw-privilege-escalation-via-unpaired-device-identity-in-shared-gateway-authentication
Get alerted when CVE-2026-32042 or the next vulnerability affects your stack