What’s Vulnerable › Vulnerabilities
CVE-2026-3206: Improper management of context cancelations
- Severity: low (CVSS 1.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-25 · updated 2026-06-17
- Weakness: CWE-404
Description
Improper Resource Shutdown or Release vulnerability in KrakenD, SLU KrakenD-CE (CircuitBreaker modules), KrakenD, SLU KrakenD-EE (CircuitBreaker modules). This issue affects KrakenD-CE: before 2.13.1; KrakenD-EE: before 2.12.5.
Affected products
- KrakenD-CE: before 2.13.1 — fixed in 2.13.1
- KrakenD-EE: before 2.12.5 — fixed in 2.12.5
How to fix
Upgrade to a fixed version: KrakenD-CE 2.13.1; KrakenD-EE 2.12.5. Check the vendor advisory for mitigations.
References
- https://www.krakend.io/blog/krakend-2.13.1-release-notes/
- https://www.krakend.io/blog/krakend-ee-2.12.5-release-notes/
Get alerted when CVE-2026-3206 or the next vulnerability affects your stack