What’s Vulnerable › Vulnerabilities
CVE-2026-32061: OpenClaw < 2026.2.17 - Arbitrary File Read via $include Directive Path Traversal
- Severity: medium (CVSS 4.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-11 · updated 2026-06-17
- Weakness: CWE-22
Description
OpenClaw versions prior to 2026.2.17 contain a path traversal vulnerability in the $include directive resolution that allows reading arbitrary local files outside the config directory boundary. Attackers with config modification capabilities can exploit this by specifying absolute paths, traversal sequences, or symlinks to access sensitive files readable by the OpenClaw process user, including API keys and credentials.
Affected products
- OpenClaw: before 2026.2.17 — fixed in 2026.2.17
How to fix
Upgrade to a fixed version: OpenClaw 2026.2.17. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/commit/d1c00dbb7c64a39e205464dae7f2a068420e91c1
- https://github.com/openclaw/openclaw/security/advisories/GHSA-56pc-6hvp-4gv4
- https://www.vulncheck.com/advisories/openclaw-arbitrary-file-read-via-include-directive-path-traversal
Get alerted when CVE-2026-32061 or the next vulnerability affects your stack