What’s Vulnerable › Vulnerabilities
CVE-2026-32063: OpenClaw 2026.2.19-2 < 2026.2.21 - Command Injection via Newline in systemd Unit Generation
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-11 · updated 2026-06-17
- Weakness: CWE-77
Description
OpenClaw version 2026.2.19-2 prior to 2026.2.21 contains a command injection vulnerability in systemd unit file generation where attacker-controlled environment values are not validated for CR/LF characters, allowing newline injection to break out of Environment= lines and inject arbitrary systemd directives. An attacker who can influence config.env.vars and trigger service install or restart can execute arbitrary commands with the privileges of the OpenClaw gateway service user.
Affected products
- OpenClaw: before 2026.2.21 — fixed in 2026.2.21
How to fix
Upgrade to a fixed version: OpenClaw 2026.2.21. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/commit/61f646c41fb43cd87ed48f9125b4718a30d38e84
- https://github.com/openclaw/openclaw/security/advisories/GHSA-vffc-f7r7-rx2w
- https://www.vulncheck.com/advisories/openclaw-command-injection-via-newline-in-systemd-unit-generation
- https://github.com/openclaw/openclaw/security/advisories/GHSA-vffc-f7r7-rx2w
Get alerted when CVE-2026-32063 or the next vulnerability affects your stack