What’s Vulnerable › Vulnerabilities
CVE-2026-32098: Parse Server has a protected fields bypass via LiveQuery subscription WHERE clause
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-11 · updated 2026-06-17
- Weakness: CWE-200
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.9 and 8.6.35, an attacker can exploit LiveQuery subscriptions to infer the values of protected fields without directly receiving them. By subscribing with a WHERE clause that references a protected field (including via dot-notation or $regex), the attacker can observe whether LiveQuery events are delivered for matching objects. This creates a boolean oracle that leaks protected field values. The attack affects any class that has both protectedFields configured in Class-Level Permissions and LiveQuery enabled. This vulnerability is fixed in 9.6.0-alpha.9 and 8.6.35.
Affected products
- parse-community parse-server: before 8.6.35; from 9.0.0 before 9.6.0; 9.6.0-alpha1, 9.6.0-alpha2, 9.6.0-alpha3, 9.6.0-alpha4, 9.6.0-alpha5, 9.6.0-alpha6 (+2) — fixed in 8.6.35, 9.6.0
How to fix
Upgrade to a fixed version: parse-community parse-server 8.6.35, 9.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/releases/tag/8.6.35
- https://github.com/parse-community/parse-server/releases/tag/9.6.0-alpha.9
- https://github.com/parse-community/parse-server/security/advisories/GHSA-j7mm-f4rv-6q6q
Get alerted when CVE-2026-32098 or the next vulnerability affects your stack