What’s Vulnerable › Vulnerabilities
CVE-2026-32137: DataEase SQL Injection Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-12 · updated 2026-06-17
- Weakness: CWE-89
Description
Dataease is an open source data visualization analysis tool. Prior to 2.10.20, The table parameter for /de2api/datasource/previewData is directly concatenated into the SQL statement without any filtering or parameterization. Since tableName is a user-controllable string, attackers can inject malicious SQL statements by constructing malicious table names. This vulnerability is fixed in 2.10.20.
Affected products
- dataease: before 2.10.20 — fixed in 2.10.20
How to fix
Upgrade to a fixed version: dataease 2.10.20. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-32137 or the next vulnerability affects your stack