What’s Vulnerable › Vulnerabilities
CVE-2026-3217: SAML SSO - Service Provider - Critical - Cross-site scripting - SA-CONTRIB-2026-018
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-25 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal SAML SSO - Service Provider allows Cross-Site Scripting (XSS).This issue affects SAML SSO - Service Provider: from 0.0.0 before 3.1.3.
Affected products
- Drupal SAML SSO - Service Provider: before 3.1.3 — fixed in 3.1.3
How to fix
Upgrade to a fixed version: Drupal SAML SSO - Service Provider 3.1.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-3217 or the next vulnerability affects your stack