What’s Vulnerable › Vulnerabilities
CVE-2026-32175: .NET Core Tampering Vulnerability
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-12 · updated 2026-08-10
- Weakness: CWE-36
Description
A tampering vulnerability exists when .NET Core improperly handles specially crafted files. An attacker who successfully exploited this vulnerability could write arbitrary files and directories to certain locations on a vulnerable system. However, an attacker would have limited control over the destination of the files and directories. To exploit the vulnerability, an attacker must send a specially crafted file to a vulnerable system. The security update fixes the vulnerability by ensuring .NET Core properly handles files.
Affected products
- Microsoft .NET: from 8.0.0 before 8.0.27; from 9.0.0 before 9.0.16 — fixed in 8.0.27, 9.0.16
- Microsoft Visual Studio 2022 version 17.14: from 17.12.0 before 17.12.20; from 17.14.0 before 17.14.32 — fixed in 17.12.20, 17.14.32
- Microsoft Visual Studio 2026 version 18.9: from 18.5.0 before 18.5.3 — fixed in 18.5.3
- Microsoft .NET: from 10.0.0 before 10.0.8 — fixed in 10.0.8
- Microsoft .NET 8.0: from 8.0.0 before 8.0.27 — fixed in 8.0.27
- Microsoft .NET 9.0: from 9.0.0 before 9.0.16 — fixed in 9.0.16
- Microsoft Visual Studio 2026 version 18.5: from 18.5.0 before 18.5.3 — fixed in 18.5.3
- Microsoft Visual Studio 2022 version 17.14: from 17.12.0 before 17.12.20 — fixed in 17.12.20
How to fix
Upgrade to a fixed version: Microsoft .NET 8.0.27, 9.0.16; Microsoft Visual Studio 2022 version 17.14 17.12.20, 17.14.32; Microsoft Visual Studio 2026 version 18.9 18.5.3; Microsoft .NET 10.0.8; Microsoft .NET 8.0 8.0.27; Microsoft .NET 9.0 9.0.16; Microsoft Visual Studio 2026 version 18.5 18.5.3; Microsoft Visual Studio 2022 version 17.14 17.12.20. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-32175 or the next vulnerability affects your stack