What’s Vulnerable › Vulnerabilities
CVE-2026-3220: Multiple Plugins - Unauthenticated Stored XSS via Minify Library
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-18 · updated 2026-06-17
- Weakness: CWE-79
Description
The Autoptimize WordPress plugin before 3.1.15, Clearfy Cache WordPress plugin before 2.4.2, Speed Optimizer WordPress plugin before 7.7.9 are vulnerable to unauthenticated Stored Cross-Site Scripting (XSS) due to a predictable replacement hash used during the HTML minification process and abusing a regular expression. This allows an attacker to inject arbitrary HTML attributes in the final HTML output by anticipating the placeholder format.
Affected products
- Autoptimize: before 3.1.15 — fixed in 3.1.15
- Clearfy Cache: before 2.4.2 — fixed in 2.4.2
- Speed Optimizer: before 7.7.9 — fixed in 7.7.9
How to fix
Upgrade to a fixed version: Autoptimize 3.1.15; Clearfy Cache 2.4.2; Speed Optimizer 7.7.9. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-3220 or the next vulnerability affects your stack