What’s Vulnerable › Vulnerabilities
CVE-2026-32227: Apache Ranger: SQL Injection vulnerability in lookup functionality
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-10 · updated 2026-10-23
- Weakness: CWE-89
Description
SQL Injection vulnerability vulnerability in Apache Ranger. This issue affects . Users are recommended to upgrade to version 2.9.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache Ranger: before 2.9.0 — fixed in 2.9.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Ranger 2.9.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/1zltfzd6rp683omrlv1zkxvkwm9d0nd2
- http://www.openwall.com/lists/oss-security/2026/08/09/3
Get alerted when CVE-2026-32227 or the next vulnerability affects your stack