What’s Vulnerable › Vulnerabilities
CVE-2026-32234: Parse Server has a SQL injection via query field name when using PostgreSQL
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-11 · updated 2026-06-17
- Weakness: CWE-89
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.10 and 8.6.36, an attacker with access to the master key can inject malicious SQL via crafted field names used in query constraints when Parse Server is configured with PostgreSQL as the database. The field name in a $regex query operator is passed to PostgreSQL using unparameterized string interpolation, allowing the attacker to manipulate the SQL query. While the master key controls what can be done through the Parse Server abstraction layer, this SQL injection bypasses Parse Server entirely and operates at the database level. This vulnerability only affects Parse Server deployments using PostgreSQL. This vulnerability is fixed in 9.6.0-alpha.10 and 8.6.36.
Affected products
- parse-community parse-server: before 8.6.36; from 9.0.0 before 9.6.0; 9.6.0-alpha1, 9.6.0-alpha2, 9.6.0-alpha3, 9.6.0-alpha4, 9.6.0-alpha5, 9.6.0-alpha6 (+3) — fixed in 8.6.36, 9.6.0
How to fix
Upgrade to a fixed version: parse-community parse-server 8.6.36, 9.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/releases/tag/8.6.36
- https://github.com/parse-community/parse-server/releases/tag/9.6.0-alpha.10
- https://github.com/parse-community/parse-server/security/advisories/GHSA-c442-97qw-j6c6
Get alerted when CVE-2026-32234 or the next vulnerability affects your stack