What’s Vulnerable › Vulnerabilities
CVE-2026-32242: Parse Server OAuth2 adapter shares mutable state across providers via singleton instance
- Severity: high (CVSS 7.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-12 · updated 2026-06-17
- Weakness: CWE-362
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.11 and 8.6.37, Parse Server's built-in OAuth2 auth adapter exports a singleton instance that is reused directly across all OAuth2 provider configurations. Under concurrent authentication requests for different OAuth2 providers, one provider's token validation may execute using another provider's configuration, potentially allowing a token that should be rejected by one provider to be accepted because it is validated against a different provider's policy. Deployments that configure multiple OAuth2 providers via the oauth2: true flag are affected. This vulnerability is fixed in 9.6.0-alpha.11 and 8.6.37.
Affected products
- parse-community parse-server: before 8.6.37; from 9.0.0 before 9.6.0; 9.6.0-alpha1, 9.6.0-alpha10, 9.6.0-alpha2, 9.6.0-alpha3, 9.6.0-alpha4, 9.6.0-alpha5 (+4) — fixed in 8.6.37, 9.6.0
How to fix
Upgrade to a fixed version: parse-community parse-server 8.6.37, 9.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/releases/tag/8.6.37
- https://github.com/parse-community/parse-server/releases/tag/9.6.0-alpha.11
- https://github.com/parse-community/parse-server/security/advisories/GHSA-2cjm-2gwv-m892
Get alerted when CVE-2026-32242 or the next vulnerability affects your stack