What’s Vulnerable › Vulnerabilities
CVE-2026-32243: Discourse: Stored XSS in discourse-ai shared conversations onebox
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-31 · updated 2026-07-24
- Weakness: CWE-79
Description
Discourse is an open-source discussion platform. From versions 2026.1.0-latest to before 2026.1.3, 2026.2.0-latest to before 2026.2.2, and 2026.3.0-latest to before 2026.3.0, an attacker with the ability to create shared AI conversations could inject arbitrary HTML and JavaScript via crafted conversation titles. This payload would execute in the browser of any user viewing the onebox preview, potentially allowing session hijacking or unauthorized actions on behalf of the victim. This issue has been patched in versions 2026.1.3, 2026.2.2, and 2026.3.0.
Affected products
- discourse: from 2026.1.0 before 2026.1.3; from 2026.2.0 before 2026.2.2; 2026.3.0 — fixed in 2026.1.3, 2026.2.2
How to fix
Upgrade to a fixed version: discourse 2026.1.3, 2026.2.2. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/cac7d618a562ce934f8dbf73cdb70066a4806b4c
- https://github.com/discourse/discourse/security/advisories/GHSA-pjc5-8x3w-rfwx
Get alerted when CVE-2026-32243 or the next vulnerability affects your stack