What’s Vulnerable › Vulnerabilities
CVE-2026-32248: Parse Server: Account takeover via operator injection in authentication data identifier
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-12 · updated 2026-06-17
- Weakness: CWE-943
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.12 and 8.6.38, an unauthenticated attacker can take over any user account that was created with an authentication provider that does not validate the format of the user identifier (e.g. anonymous authentication). By sending a crafted login request, the attacker can cause the server to perform a pattern-matching query instead of an exact-match lookup, allowing the attacker to match an existing user and obtain a valid session token for that user's account. Both MongoDB and PostgreSQL database backends are affected. Any Parse Server deployment that allows anonymous authentication (enabled by default) is vulnerable. This vulnerability is fixed in 9.6.0-alpha.12 and 8.6.38.
Affected products
- parse-community parse-server: before 8.6.38; from 9.0.0 before 9.6.0; 9.6.0-alpha1, 9.6.0-alpha10, 9.6.0-alpha11, 9.6.0-alpha2, 9.6.0-alpha3, 9.6.0-alpha4 (+5) — fixed in 8.6.38, 9.6.0
How to fix
Upgrade to a fixed version: parse-community parse-server 8.6.38, 9.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/releases/tag/8.6.38
- https://github.com/parse-community/parse-server/releases/tag/9.6.0-alpha.12
- https://github.com/parse-community/parse-server/security/advisories/GHSA-5fw2-8jcv-xh87
Get alerted when CVE-2026-32248 or the next vulnerability affects your stack