What’s Vulnerable › Vulnerabilities
CVE-2026-32264: Craft CMS vulnerable to behavior injection RCE ElementIndexesController and FieldsController
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-16 · updated 2026-06-17
- Weakness: CWE-470
Description
Craft CMS is a content management system (CMS). From version 4.0.0-RC1 to before version 4.17.5 and from version 5.0.0-RC1 to before version 5.9.11, there is a Behavior injection RCE vulnerability in ElementIndexesController and FieldsController. Craft control panel administrator permissions and allowAdminChanges must be enabled for this to work. This issue has been patched in versions 4.17.5 and 5.9.11.
Affected products
- craftcms cms: from 4.0.0.1 before 4.17.5; from 5.0.1 before 5.9.11; 4.0.0, 4.0.0-rc1, 4.0.0-rc2, 4.0.0-rc3, 5.0.0, 5.0.0-rc1 — fixed in 4.17.5, 5.9.11
How to fix
Upgrade to a fixed version: craftcms cms 4.17.5, 5.9.11. Check the vendor advisory for mitigations.
References
- https://github.com/craftcms/cms/commit/78d181e12e0b15e1300f54ec85f19859d3300f70
- https://github.com/craftcms/cms/commit/dfec46362fcb40b330ce8a4d8136446e65085620
- https://github.com/craftcms/cms/security/advisories/GHSA-4484-8v2f-5748
- https://github.com/craftcms/cms/security/advisories/GHSA-7jx7-3846-m7w7
Get alerted when CVE-2026-32264 or the next vulnerability affects your stack