What’s Vulnerable › Vulnerabilities
CVE-2026-32266: Google Cloud Storage for Craft CMS has an Information Disclosure Vulnerability
- Severity: low (CVSS 2.4 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-18 · updated 2026-06-17
- Weakness: CWE-200
Description
The Google Cloud Storage for Craft CMS plugin provides a Google Cloud Storage integration for Craft CMS. In versions on the 2.x branch prior to 2.2.1, the `DefaultController->actionLoadBucketData()` endpoint allows unauthenticated users with a valid CSRF token to view a list of buckets that the plugin is allowed to see. Users should update to version 2.2.1 of the plugin to mitigate the issue.
Affected products
- craftcms google-cloud: from 2.0.0-beta.1, < 2.2.1
References
- https://github.com/craftcms/google-cloud/commit/651bacaa5f5fd7813e4075e0747b1d706391fb2c
- https://github.com/craftcms/google-cloud/security/advisories/GHSA-67cr-jmh8-4jpq
Get alerted when CVE-2026-32266 or the next vulnerability affects your stack