What’s Vulnerable › Vulnerabilities
CVE-2026-32267: Craft CMS Vulnerable to Privilege Escalation/Bypass through UsersController->actionImpersonateWithToken()
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 9.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-16 · updated 2026-06-17
- Weakness: CWE-863
Description
Craft CMS is a content management system (CMS). From version 4.0.0-RC1 to before version 4.17.6 and from version 5.0.0-RC1 to before version 5.9.12, a low-privilege user (or an unauthenticated user who has been sent a shared URL) can escalate their privileges to admin by abusing UsersController->actionImpersonateWithToken. This issue has been patched in versions 4.17.6 and 5.9.12.
Affected products
- craftcms cms: from 4.0.0.1 before 4.17.6; from 5.0.1 before 5.9.12; 4.0.0, 4.0.0-rc1, 4.0.0-rc2, 4.0.0-rc3, 5.0.0, 5.0.0-rc1 — fixed in 4.17.6, 5.9.12
How to fix
Upgrade to a fixed version: craftcms cms 4.17.6, 5.9.12. Check the vendor advisory for mitigations.
References
- https://github.com/craftcms/cms/commit/6301e217c5f15617d939c432cb770db50af14b33
- https://github.com/craftcms/cms/security/advisories/GHSA-cc7p-2j3x-x7xf
- https://github.com/craftcms/cms/security/advisories/GHSA-cc7p-2j3x-x7xf
Get alerted when CVE-2026-32267 or the next vulnerability affects your stack