What’s Vulnerable › Vulnerabilities
CVE-2026-32269: Parse Server OAuth2 adapter app ID validation sends wrong token to introspection endpoint
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-12 · updated 2026-06-17
- Weakness: CWE-683
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.13 and 8.6.39, the OAuth2 authentication adapter does not correctly validate app IDs when appidField and appIds are configured. During app ID validation, a malformed value is sent to the token introspection endpoint instead of the user's actual access token. Depending on the introspection endpoint's behavior, this could either cause all OAuth2 logins to fail, or allow authentication from disallowed app contexts if the endpoint returns valid-looking data for the malformed request. Deployments using the OAuth2 adapter with appidField and appIds configured are affected. This vulnerability is fixed in 9.6.0-alpha.13 and 8.6.39.
Affected products
- parse-community parse-server: from 8.0.2 before 8.6.39; from 9.0.0 before 9.6.0; 9.6.0-alpha1, 9.6.0-alpha10, 9.6.0-alpha11, 9.6.0-alpha12, 9.6.0-alpha2, 9.6.0-alpha3 (+6) — fixed in 8.6.39, 9.6.0
How to fix
Upgrade to a fixed version: parse-community parse-server 8.6.39, 9.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/releases/tag/8.6.39
- https://github.com/parse-community/parse-server/releases/tag/9.6.0-alpha.13
- https://github.com/parse-community/parse-server/security/advisories/GHSA-69xg-f649-w5g2
Get alerted when CVE-2026-32269 or the next vulnerability affects your stack