What’s Vulnerable › Vulnerabilities

CVE-2026-32273: Discourse: XSS on category description update via API

Description

Discourse is an open-source discussion platform. From versions 2026.1.0-latest to before 2026.1.3, 2026.2.0-latest to before 2026.2.2, and 2026.3.0-latest to before 2026.3.0, updating a category description via API is not sanitizing the description string, which can lead to XSS attacks. This issue has been patched in versions 2026.1.3, 2026.2.2, and 2026.3.0.

Affected products

How to fix

Upgrade to a fixed version: discourse 2026.1.3, 2026.2.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-32273 or the next vulnerability affects your stack