What’s Vulnerable › Vulnerabilities
CVE-2026-32276: Connect-CMS has Arbitrary Code Execution by an Authenticated User in its Code Study Plugin
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-23 · updated 2026-06-17
- Weakness: CWE-94
Description
Connect-CMS is a content management system. In versions on the 1.x series up to and including 1.41.0 and versions on the 2.x series up to and including 2.41.0, an authenticated user may be able to execute arbitrary code in the Code Study Plugin. Versions 1.41.1 and 2.41.1 contain a patch.
Affected products
- opensource-workshop connect-cms: from 1.0.0 before 1.41.1; from 2.0.0 before 2.41.1 — fixed in 1.41.1, 2.41.1
How to fix
Upgrade to a fixed version: opensource-workshop connect-cms 1.41.1, 2.41.1. Check the vendor advisory for mitigations.
References
- https://github.com/opensource-workshop/connect-cms/commit/c0bcd07fc1e9375941aa1295d044328ecd44ed85
- https://github.com/opensource-workshop/connect-cms/releases/tag/v1.41.1
- https://github.com/opensource-workshop/connect-cms/releases/tag/v2.41.1
- https://github.com/opensource-workshop/connect-cms/security/advisories/GHSA-hxqw-6qv7-cqfv
Get alerted when CVE-2026-32276 or the next vulnerability affects your stack