What’s Vulnerable › Vulnerabilities
CVE-2026-32279: Connect CMS has SSRF in the External Page Migration Feature of its Page Management Plugin
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-23 · updated 2026-06-17
- Weakness: CWE-918
Description
Connect-CMS is a content management system. In versions on the 1.x series up to and including 1.41.0 and versions on the 2.x series up to and including 2.41.0, a Server-Side Request Forgery (SSRF) issue exists in the external page migration feature of the Page Management Plugin. Versions 1.41.1 and 2.41.1 contain a patch.
Affected products
- opensource-workshop connect-cms: from 1.0.0 before 1.41.1; from 2.0.0 before 2.41.1 — fixed in 1.41.1, 2.41.1
How to fix
Upgrade to a fixed version: opensource-workshop connect-cms 1.41.1, 2.41.1. Check the vendor advisory for mitigations.
References
- https://github.com/opensource-workshop/connect-cms/commit/4a1a64a8f768a53e06a4239e25782d9e2e88fc63
- https://github.com/opensource-workshop/connect-cms/commit/617a874e14b8476da7c0760a06384b9da21bdd4f
- https://github.com/opensource-workshop/connect-cms/releases/tag/v1.41.1
- https://github.com/opensource-workshop/connect-cms/releases/tag/v2.41.1
- https://github.com/opensource-workshop/connect-cms/security/advisories/GHSA-jh46-85jr-6ph9
Get alerted when CVE-2026-32279 or the next vulnerability affects your stack