What’s Vulnerable › Vulnerabilities
CVE-2026-32285: Denial of service in github.com/buger/jsonparser
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-26 · updated 2026-09-09
- Weakness: CWE-129
Description
The Delete function fails to properly validate offsets when processing malformed JSON input. This can lead to a negative slice index and a runtime panic, allowing a denial of service attack.
Affected products
- github.com/buger/jsonparser: before 1.1.2 — fixed in 1.1.2
How to fix
Upgrade to a fixed version: github.com/buger/jsonparser 1.1.2. Check the vendor advisory for mitigations.
References
- https://github.com/buger/jsonparser/issues/275
- https://github.com/golang/vulndb/issues/4514
- https://pkg.go.dev/vuln/GO-2026-4514
- https://access.redhat.com/errata/RHSA-2026:13548
- https://access.redhat.com/errata/RHSA-2026:17121
- https://access.redhat.com/errata/RHSA-2026:17123
- https://access.redhat.com/errata/RHSA-2026:19099
- https://access.redhat.com/errata/RHSA-2026:21769
- https://access.redhat.com/errata/RHSA-2026:22347
- https://access.redhat.com/errata/RHSA-2026:22423
- https://access.redhat.com/errata/RHSA-2026:23345
- https://access.redhat.com/errata/RHSA-2026:34364
Get alerted when CVE-2026-32285 or the next vulnerability affects your stack