What’s Vulnerable › Vulnerabilities
CVE-2026-32300: Connect CMS: Improper Authorization in the My Page Profile Update Feature Allows Modification of Arbitrary User Information
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-23 · updated 2026-06-17
- Weakness: CWE-285
Description
Connect-CMS is a content management system. In versions on the 1.x series up to and including 1.41.0 and versions on the 2.x series up to and including 2.41.0, an improper authorization issue in the My Page profile update feature may allow modification of arbitrary user information. Versions 1.41.1 and 2.41.1 contain a patch.
Affected products
- opensource-workshop connect-cms: from 1.0.0 before 1.41.1; from 2.0.0 before 2.41.1 — fixed in 1.41.1, 2.41.1
How to fix
Upgrade to a fixed version: opensource-workshop connect-cms 1.41.1, 2.41.1. Check the vendor advisory for mitigations.
References
- https://github.com/opensource-workshop/connect-cms/commit/7c9951738c62a1d51b91e9956d1eb756c5d52cce
- https://github.com/opensource-workshop/connect-cms/releases/tag/v1.41.1
- https://github.com/opensource-workshop/connect-cms/releases/tag/v2.41.1
- https://github.com/opensource-workshop/connect-cms/security/advisories/GHSA-qr6x-wvxr-8hm9
Get alerted when CVE-2026-32300 or the next vulnerability affects your stack