What’s Vulnerable › Vulnerabilities
CVE-2026-32323: Mullvad VPN for macOS: Local Privilege Escalation via unverified bundle path in installer
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-19 · updated 2026-07-24
- Weakness: CWE-269
Description
Mullvad VPN is a VPN client app for desktop and mobile. When using macOS with versions 2026.1 and below, Mullvad VPN may allow local privilege escalation during installation or upgrade. The installer package executes binaries from /Applications/Mullvad VPN.app without verifying if the bundle is attacker-controlled or that the path is the legitimate Mullvad application. A user in the admin group can pre-place a crafted application bundle at that location and may be able to achieve code execution as root. Since the issue only affected the installer, there is no immediate need for users to update if they are already running an older version. This issue has been fixed in version 2026.2-beta1.
Affected products
- mullvadvpn-app: before 2026.2 — fixed in 2026.2
How to fix
Upgrade to a fixed version: mullvadvpn-app 2026.2. Check the vendor advisory for mitigations.
References
- https://github.com/mullvad/mullvadvpn-app/commit/032fdcb927c0b6d3e5e1aba4140d33adf22a6bfb
- https://github.com/mullvad/mullvadvpn-app/security/advisories/GHSA-c2g6-w5fq-vw3m
Get alerted when CVE-2026-32323 or the next vulnerability affects your stack