What’s Vulnerable › Vulnerabilities

CVE-2026-3240: Concrete CMS below 9.4.8 is vulnerable to Stored XSS via Legacy form

Description

In Concrete CMS below version 9.4.8, a user with permission to edit a page with element Legacy form can perform a stored XSS attack towards high-privilege accounts via the Question field. The Concrete CMS security team gave this vulnerability a CVSS v.4.0 score of 4.8 with vector CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N Thanks minhnn42, namdi and quanlna2 from VCSLab-Viettel Cyber Security for reporting.

Affected products

How to fix

Upgrade to a fixed version: Concrete CMS 9.4.8. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-3240 or the next vulnerability affects your stack