What’s Vulnerable › Vulnerabilities
CVE-2026-3242: Concrete CMS below 9.4.8 is vulnerable to Stored XSS in the Switch Language block
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-04 · updated 2026-06-17
- Weakness: CWE-79
Description
In Concrete CMS below version 9.4.8, a rogue administrator can add stored XSS via the Switch Language block. The Concrete CMS security team gave this vulnerability a CVSS v.4.0 score of 4.8 with vector CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N. Thanks M3dium for reporting.
Affected products
- Concrete CMS: before 9.4.8 — fixed in 9.4.8
How to fix
Upgrade to a fixed version: Concrete CMS 9.4.8. Check the vendor advisory for mitigations.
References
- https://documentation.concretecms.org/9-x/developers/introduction/version-history/948-release-notes
- https://github.com/concretecms/concretecms/pull/12826
Get alerted when CVE-2026-3242 or the next vulnerability affects your stack