What’s Vulnerable › Vulnerabilities
CVE-2026-3257: UnQLite versions through 0.06 for Perl uses a potentially insecure version of the UnQLite library
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-05 · updated 2026-06-17
- Weakness: CWE-1395
Description
UnQLite versions through 0.06 for Perl uses a potentially insecure version of the UnQLite library. UnQLite for Perl embeds the UnQLite library. Version 0.06 and earlier of the Perl module uses a version of the library from 2014 that may be vulnerable to a heap-based overflow.
Affected products
- TOKUHIROM UnQLite: before 0.07 — fixed in 0.07
How to fix
Upgrade to a fixed version: TOKUHIROM UnQLite 0.07. Check the vendor advisory for mitigations.
References
- https://metacpan.org/release/TOKUHIROM/UnQLite-0.07/source/Changes
- https://unqlite.symisc.net/
- https://www.cve.org/CVERecord?id=CVE-2025-3791
Get alerted when CVE-2026-3257 or the next vulnerability affects your stack