What’s Vulnerable › Vulnerabilities
CVE-2026-32594: Parse Server GraphQL WebSocket endpoint bypasses security middleware
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-16 · updated 2026-06-17
- Weakness: CWE-306
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 8.6.40 and 9.6.0-alpha.14, the GraphQL WebSocket endpoint for subscriptions does not pass requests through the Express middleware chain that enforces authentication, introspection control, and query complexity limits. An attacker can connect to the WebSocket endpoint and execute GraphQL operations without providing a valid application or API key, access the GraphQL schema via introspection even when public introspection is disabled, and send arbitrarily complex queries that bypass configured complexity limits. This vulnerability is fixed in 8.6.40 and 9.6.0-alpha.14.
Affected products
- parse-community parse-server: before 8.6.40; from 9.0.0 before 9.6.0; 9.6.0-alpha1, 9.6.0-alpha10, 9.6.0-alpha11, 9.6.0-alpha12, 9.6.0-alpha13, 9.6.0-alpha2 (+7) — fixed in 8.6.40, 9.6.0
How to fix
Upgrade to a fixed version: parse-community parse-server 8.6.40, 9.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/pull/10189
- https://github.com/parse-community/parse-server/pull/10190
- https://github.com/parse-community/parse-server/security/advisories/GHSA-p2x3-8689-cwpg
Get alerted when CVE-2026-32594 or the next vulnerability affects your stack