What’s Vulnerable › Vulnerabilities
CVE-2026-32604: Spinnaker vulnerable to RCE when using gitrepo artifact types due to improper sanitization of user input on branch and paths
- Severity: critical (CVSS 9.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-20 · updated 2026-06-17
- Weakness: CWE-20
Description
Spinnaker is an open source, multi-cloud continuous delivery platform. In versions prior to 2026.1.0, 2026.0.1, 2025.4.2, and 2025.3.2, a bad actor can execute arbitrary commands very simply on the clouddriver pods. This can expose credentials, remove files, or inject resources easily. Versions 2026.1.0, 2026.0.1, 2025.4.2, and 2025.3.2 contain a patch. As a workaround, disable the gitrepo artifact types.
Affected products
- spinnaker: before 2025.3.2; from 2025.4.0 before 2025.4.2; from 2026.0.0 before 2026.0.1 — fixed in 2025.3.2, 2025.4.2, 2026.0.1
How to fix
Upgrade to a fixed version: spinnaker 2025.3.2, 2025.4.2, 2026.0.1. Check the vendor advisory for mitigations.
References
- https://github.com/spinnaker/spinnaker/releases/tag/spinnaker-release-2025.3.2
- https://github.com/spinnaker/spinnaker/releases/tag/spinnaker-release-2025.4.2
- https://github.com/spinnaker/spinnaker/releases/tag/spinnaker-release-2026.0.1
- https://github.com/spinnaker/spinnaker/security/advisories/GHSA-x3j7-7pgj-h87r
- https://zeropath.com/blog/spinnaker-rce-production-compromise
Get alerted when CVE-2026-32604 or the next vulnerability affects your stack