What’s Vulnerable › Vulnerabilities
CVE-2026-32612: Statamic: privilege escalation via stored cross-site scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-13 · updated 2026-06-17
- Weakness: CWE-79
Description
Statamic is a Laravel and Git powered content management system (CMS). Prior to 6.6.2, stored XSS in the control panel color mode preference allows authenticated users with control panel access to inject malicious JavaScript that executes when a higher-privileged user impersonates their account. This has been fixed in 6.6.2.
Affected products
- Statamic: from 6.0.0 before 6.6.2 — fixed in 6.6.2
How to fix
Upgrade to a fixed version: Statamic 6.6.2. Check the vendor advisory for mitigations.
References
- https://github.com/Shirshaw64p/security-advisories/tree/main/CVE-2026-32612
- https://github.com/statamic/cms/security/advisories/GHSA-hcch-w73c-jp4m
Get alerted when CVE-2026-32612 or the next vulnerability affects your stack