What’s Vulnerable › Vulnerabilities
CVE-2026-32613: Spinnaker vulnerable to RCE via expression parsing due to unrestricted context handling
- Severity: critical (CVSS 9.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-20 · updated 2026-06-17
- Weakness: CWE-94
Description
Spinnaker is an open source, multi-cloud continuous delivery platform. Echo like some other services, uses SPeL (Spring Expression Language) to process information - specifically around expected artifacts. In versions prior to 2026.1.0, 2026.0.1, 2025.4.2, and 2025.3.2, unlike orca, it was NOT restricting that context to a set of trusted classes, but allowing FULL JVM access. This enabled a user to use arbitrary java classes which allow deep access to the system. This enabled the ability to invoke commands, access files, etc. Versions 2026.1.0, 2026.0.1, 2025.4.2, and 2025.3.2 contain a patch. As a workaround, disable echo entirely.
Affected products
- spinnaker: before 2025.3.2; from 2025.4.0 before 2025.4.2; from 2026.0.0 before 2026.0.1 — fixed in 2025.3.2, 2025.4.2, 2026.0.1
How to fix
Upgrade to a fixed version: spinnaker 2025.3.2, 2025.4.2, 2026.0.1. Check the vendor advisory for mitigations.
References
- https://github.com/spinnaker/spinnaker/releases/tag/spinnaker-release-2025.3.2
- https://github.com/spinnaker/spinnaker/releases/tag/spinnaker-release-2025.4.2
- https://github.com/spinnaker/spinnaker/releases/tag/spinnaker-release-2026.0.1
- https://github.com/spinnaker/spinnaker/security/advisories/GHSA-69rw-45wj-g4v6
- https://zeropath.com/blog/spinnaker-rce-production-compromise
Get alerted when CVE-2026-32613 or the next vulnerability affects your stack