What’s Vulnerable › Vulnerabilities
CVE-2026-32615: Discourse: Category group moderators can perform actions on topics in restricted categories without read access
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-31 · updated 2026-07-24
- Weakness: CWE-285
Description
Discourse is an open-source discussion platform. From versions 2026.1.0-latest to before 2026.1.3, 2026.2.0-latest to before 2026.2.2, and 2026.3.0-latest to before 2026.3.0, category group moderators could perform privileged actions on topics inside private categories they did not have read access to. This issue has been patched in versions 2026.1.3, 2026.2.2, and 2026.3.0.
Affected products
- discourse: from 2026.1.0 before 2026.1.3; from 2026.2.0 before 2026.2.2; 2026.3.0 — fixed in 2026.1.3, 2026.2.2
How to fix
Upgrade to a fixed version: discourse 2026.1.3, 2026.2.2. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/5a00b47523ec70cbb6e8efc3ac7677cc0a91448b
- https://github.com/discourse/discourse/security/advisories/GHSA-pr9m-5hpq-wc57
Get alerted when CVE-2026-32615 or the next vulnerability affects your stack