What’s Vulnerable › Vulnerabilities

CVE-2026-32619: Discourse: Insufficient topic visibility check allows unauthorized poll manipulation in private categories

Description

Discourse is an open-source discussion platform. From versions 2026.1.0-latest to before 2026.1.3, 2026.2.0-latest to before 2026.2.2, and 2026.3.0-latest to before 2026.3.0, users who lost access to a topic (e.g., removed from a private category group) could still interact with polls in that topic, including voting and toggling poll status. No content was exposed, but users could modify poll state in topics they should no longer have access to. This issue has been patched in versions 2026.1.3, 2026.2.2, and 2026.3.0.

Affected products

How to fix

Upgrade to a fixed version: discourse 2026.1.3, 2026.2.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-32619 or the next vulnerability affects your stack