What’s Vulnerable › Vulnerabilities

CVE-2026-32620: Discourse: Missing post-level authorization allows whisper metadata disclosure

Description

Discourse is an open-source discussion platform. From versions 2026.1.0-latest to before 2026.1.3, 2026.2.0-latest to before 2026.2.2, and 2026.3.0-latest to before 2026.3.0, non-staff users could access read receipt information for staff-only posts they weren't supposed to see. No post content was exposed, only metadata about who read the post and when. This issue has been patched in versions 2026.1.3, 2026.2.2, and 2026.3.0.

Affected products

How to fix

Upgrade to a fixed version: discourse 2026.1.3, 2026.2.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-32620 or the next vulnerability affects your stack