What’s Vulnerable › Vulnerabilities
CVE-2026-32633: Glances's Browser API Exposes Reusable Downstream Credentials via `/api/4/serverslist`
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-18 · updated 2026-06-17
- Weakness: CWE-200
Description
Glances is an open-source system cross-platform monitoring tool. Prior to version 4.5.2, in Central Browser mode, the `/api/4/serverslist` endpoint returns raw server objects from `GlancesServersList.get_servers_list()`. Those objects are mutated in-place during background polling and can contain a `uri` field with embedded HTTP Basic credentials for downstream Glances servers, using the reusable pbkdf2-derived Glances authentication secret. If the front Glances Browser/API instance is started without `--password`, which is supported and common for internal network deployments, `/api/4/serverslist` is completely unauthenticated. Any network user who can reach the Browser API can retrieve reusable credentials for protected downstream Glances servers once they have been polled by the browser instance. Version 4.5.2 fixes the issue.
Affected products
- nicolargo glances: before 4.5.2 — fixed in 4.5.2
How to fix
Upgrade to a fixed version: nicolargo glances 4.5.2. Check the vendor advisory for mitigations.
References
- https://github.com/nicolargo/glances/commit/879ef8688ffa1630839549751d3c7ef9961d361e
- https://github.com/nicolargo/glances/releases/tag/v4.5.2
- https://github.com/nicolargo/glances/security/advisories/GHSA-r297-p3v4-wp8m
- https://github.com/nicolargo/glances/security/advisories/GHSA-r297-p3v4-wp8m
Get alerted when CVE-2026-32633 or the next vulnerability affects your stack