What’s Vulnerable › Vulnerabilities
CVE-2026-32635: Angular has XSS in i18n attribute bindings
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-16 · updated 2026-06-17
- Weakness: CWE-79
Description
Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 22.0.0-next.3, 21.2.4, 20.3.18, and 19.2.20, a Cross-Site Scripting (XSS) vulnerability has been identified in the Angular runtime and compiler. It occurs when the application uses a security-sensitive attribute (for example href on an anchor tag) together with Angular's ability to internationalize attributes. Enabling internationalization for the sensitive attribute by adding i18n-<attribute> name bypasses Angular's built-in sanitization mechanism, which when combined with a data binding to untrusted user-generated data can allow an attacker to inject a malicious script. This vulnerability is fixed in 22.0.0-next.3, 21.2.4, 20.3.18, and 19.2.20.
Affected products
- angular-cli: from 17.0.0 before 19.2.0; from 20.0.0 through 20.3.18; from 21.0.0 before 21.2.4; 22.0.0-next0, 22.0.0-next1 — fixed in 19.2.0, 21.2.4
How to fix
Upgrade to a fixed version: angular-cli 19.2.0, 21.2.4. Check the vendor advisory for mitigations.
References
- https://github.com/angular/angular/pull/67541
- https://github.com/angular/angular/pull/67561
- https://github.com/angular/angular/security/advisories/GHSA-g93w-mfhg-p222
Get alerted when CVE-2026-32635 or the next vulnerability affects your stack