What’s Vulnerable › Vulnerabilities
CVE-2026-32641: Parseable: Unauthenticated Denial of Service via panic in Kinesis header parsing middleware
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-18 · updated 2026-09-24
- Weakness: CWE-248
Description
Parseable is a log analytics platform built for high-volume data ingestion and analysis. Prior to 3.0.0, src/handlers/http/middleware.rs uses unwrap() while parsing the x-amz-firehose-common-attributes header before authentication. A remote unauthenticated attacker can supply non-UTF-8 header data, malformed JSON, or invalid derived header values that trigger a Rust panic and interrupt request handling, allowing repeated requests to deny service or cause container restart loops. This issue is fixed in version 3.0.0.
Affected products
- parseablehq parseable: before 3.0.0
References
- https://github.com/parseablehq/parseable/commit/6c583081a4161476128f330b9bb71ed7305eecde
- https://github.com/parseablehq/parseable/pull/1581
- https://github.com/parseablehq/parseable/releases/tag/v3.0.0
- https://github.com/parseablehq/parseable/security/advisories/GHSA-x4q9-j9qh-3rpx
Get alerted when CVE-2026-32641 or the next vulnerability affects your stack