What’s Vulnerable › Vulnerabilities
CVE-2026-32682: NGINX Gateway Fabric vulnerability
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-17 · updated 2026-10-26
- Weakness: CWE-129
Description
When NGINX Gateway Fabric is configured using GRPCRoutes, an authenticated, remote attacker with permission to create or modify GRPCRoute resources can cause the NGINX Gateway Fabric control plane to terminate by sending undisclosed GRPCRoute configurations containing backendRef filters. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
Affected products
- F5 NGINX Gateway Fabric: from 1.3.0 through 1.6.2; from 2.0.0 before 2.6.4 — fixed in 2.6.4
How to fix
Upgrade to a fixed version: F5 NGINX Gateway Fabric 2.6.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-32682 or the next vulnerability affects your stack